Niagara trail bug

My trails just connect from one to another like glitches, what is the cause and how can I fix it?image

Seems to be working fine for me.

Maybe it’s your setup? Can you post your setup? Are you using a parent/source emitter to spawn the ribbon?
What you can always try, is to set the RibbonLinkOrder manually. The RibbonLinkOrder defines how the Ribbon is linked together. You can, for example set it to the NormalizedAge. Or anything really, that goes from 0-1, to define the order you need.

1 Like

I’m currently using UE5 and it seems it only bugs here. The previous version was fine.
My setup is pretty common. I use a Source and spawn Trail using Event from it. Persistent IDs are checked for both.


The problem is: When a source-ribbon dies, the ribbon instantly connect to the new/current running ones, like glitches. And it’s more clear when I increase lifetime, or lifetime random float difference is high.

It still doesn’t work. Setting the ribbon link order like ur setup.
20211216_094812

For what it’s worth, my studio is on UE5 as well and I have had this problem before and I honestly don’t think I figured out a way to fix it.

1 Like

not sure, but i think you should lower the loop duration of trails than source particle loop duration.

It doesn’t work. Also, I set both of them loop behavior = infinity with loop duration = 1.
Actually, I think it’s more like a bug since it works correctly in previous versions.

1 Like

Hi Jukerlaw, I think I managed to get rid of this issue by changing the way I spawned my trails. I used to sample the location of the lead particles by using a location event, but since I changed it to a Spawn From Other Emitter method (Dismiss the issue about not having initialize particle, and use initialize ribbon instead) the problem doesn’t seem to occure anymore.

Let me know if that fixed it for you, or if you found another workaround.

hey thank you for your solution. Right now I don’t have a workstation, but I’ll definitely try it and let you know later.