Gooey texture pixelated in the material preview

Hello everyone ! :sparkles:

I’m currently working on an “ink” slash effect in UE5 by following and modifying the shader from VFX Apprentice’s Water studies. (trying, at least :sweat_smile: )

So far here’s what I got :

initial gif

As you can see, in the viewport it looks fine as long as I don’t get too close and the movement gives it a “gooey” feeling. However the Tiling X being at -0.1 makes the texture very pixelated in the material preview :


However, if I put Tiling X at 1, here’s what it gives me :

It’s a bit less pixelated but has lost all of the “gooey” movement (it doesn’t move at all anymore). I feel like keeping the Tiling X at -0.1 is probably going to be problematic down the line so I was wondering if someone has a better method for doing this :smiling_face_with_three_hearts:

1 Like

What are your texture settings set to? BC7 should make it less pixellated as the compression is ‘better’ :slight_smile:

1 Like

The compression settings were indeed set to BC1 !
I couldn’t find BC7 so I settled for “HDR Compressed - BC6H” and it fixed it ! Thank you very much :smile:

1 Like