Unreal | Niagara | Ribbon ZigZags

Hi, I have been having this ribbon issue since UE 5.1 and I’m still fighting with it, does anyone know how to fix the zigzags and the lines there as well? I saw a guy referring to texture smearing and fixing it by typing commands to the console but that was a while ago and I can’t even remember those commands…thank you for your response guys!:slight_smile:

1 Like

Hi, this is an issue with uv interpolation on stretched triangles.
You can reduce the stretchyness of the triangles on the ribbon by adding control edges.
Try increasing the “Width Segmentation Count” in the ribbon renderer settings (under shape)
Be careful not to add too much since this increases vertex count


I can’t even describe it…I was, to be honest hopeless with ribbons, I tried so many stuff to try to fix the issue since UE 5.1 until I just gave up, and I remember at that time I tried what you typed also, but completely forgot about it now, so I went to try it, I put a value of 6 went to see the VFX and it completely changed was looking 10times better and also no lines no zigzags everything how it should be. I was speechless… you are a lifesaver!