Niagara / unreal GDC

unreal

#227

Simple trees)


#228

Next experiment with event handler in Niagara


#229

Has anyone come up with a way to relocate the emmiter from 0,0,0 world space to the emmiter in the level. Everytime I put a linear distance into a level it only spawns at the world zero


#230

You need to use a System Location module in your Particle Spawn script


#231

#232

@cannabis.cod3r hey did you ever end up making a copy offset for the radial distribution like the one you had for linear distribution?


#233

@Docsnaught I don’t remember…but the implementation should be identical.


#234

This is the issue I’m having with getting the implementation to work. I know im missing something that would allow me to use the index of each radial distribution on each new copy. currently it just divides the rotation among the copies.


#235



#236

Finally created an effect that I haven’t seen on here yet. Based on @cannabis.cod3r’s work with radials. Thank you for the mention in your video post today and all of your help on the forums.


#237

My next experiment))


#238

Sorry this was not actually a reply to AR, I hit the wrong button…anyway.

fMod bug?

I have been working through Ash’s tutorials. When I got to the Color to Space tute I ran in to a bug that seems to be in the fMod node. I have a very simple fMod script that is also showing this error.

Whats extra strange is that the CtS tut uses the Grid Distribution project as a base. And it seems to work just fine. I have attached screen shots to show the issue. I am coming from a production art background and so I am curious to have eyes on my analysis and see if its not user error some how or is in fact a bug.

Here is the way the issue first surfaced.

Isolating the fMod node and the resulting errors.


#239

Hi) Try to transfer “ModuloUnderstand” to Partycle Spawn.


#240


#241

#242

Moved it to Particle Spawn… still getting odd results.

This is just with the very simple script that just does the modulo operation and reports the results. SO which spot its in, Spawn or Update shouldn’t matter right? Specific to the Color to Space tut is there is an fMod in the script that is part of PU. SO it just seems that fMod is broken?


#243

I reproduce, but all is true…




#244

Try playing with your input values. I found some would work but then it breaks.

Actually I just tried your values 200 and 100 and that does work in my case too.

Try Spawn count 600, fMod 200.

I am on 4.20.2 btw


#245

caught errors


#246

I think I remember discovering that ArrayIndex != ExecIndex (you can verify this by writing out Particles.MyExecIndex). For consistent indices, you’ll want to enable Persistent IDs in the Emitter spawn properties. After that, you can reference Particles.ID in your scripts. You’ll also want to Floor the result for good measure…

Note: persistent IDs (currently) don’t work with GPU sim.