Mesh Renderer stutters at Sequencer

Hello great community!
It’s my 1st post here, and it’s about Unreal 5.

I’m stuck with a technical issue.
Unreal 5.0.2 and 5.0.3

I’ve made a complex effect consisting of sprite renderers, sprite+light, mesh, 8 emitters in total.
When putting it into Sequencer and assigninng movement to Niagara system, it stucks at previous frame instead of smooth moving, letting all “Lifetime” play in the previous frame → stuttering appears.

It happens always to Mesh renderer.
It also happens to big sprite renderers, little sprites move as intended.

Rendering movie at 60 FPS changes nothing.

I’m thinking, maybe there is a way to avoid sequencer for moving?
For example, assigning same path (curl noise?) for the whole system (by setting a parameter). I tried Component Renderer, it’s pain.
Or, maybe, blueprint?

The ideal option would be to know how to avoid stuttering inside Sequencer though.
I’d be very thankful for help!

#vfx #unreal #ue5 #sequencer

Hi vfxena,

Would it be possible to get a video clip of the effect or a screen grab of the properties of the emitters that are not behaving? It’s hard to tell what exactly might be causing the issue.

The only guess I have right now is that Local Space isn’t on, so that the spawned particle is stationary dies and a new one spawned at the systems new location giving a stuttering appearance.

You can turn on local space per emitter by clicking on the emitter Properties and checking the box for Local Space.

Hope I guessed the issue, if not a video would help a lot.

1 Like

Very hard from your screenshot to see what the actual problem is.
Moving effects/meshes e.g. via attachment, might sometimes be one frame behind. What you could try to do is maybe use a fixed tick rate in Niagara. There is also some tick options in blueprint I think, regarding the tick order. Or maybe some options related to this in sequencer directly.

2 Likes

Thank you! It’s the most elegant decision in this situation. It worked!
meshstutteringfix
(I will fix the spawn rate to avoid “tail effect” but this is how it works now. at least the idea)

I understood, next time when I have questions I’ll make a video/gif of it :slight_smile:

2 Likes

Thank you! I had an idea that it might be the issue but didn’t know where to fix it. It is not the case now (happily), but for future I will know and thus I’m grateful for you advice ahead of time :slight_smile: