Houdini RBD Simulation to Unreal Issues - SOLVED

simulations
houdini
ue4
unreal
vfx

#1

Hey guys. I’ve got some problem getting my very simple “falling tree” simulation working correctly in Unreal via Vertex Animatio Textures. The exported simulation seems to be offset or something ¯_(ツ)_/¯

In Houdini I’ve got a simple mesh which I convert into a RBD Packed Object. In the DOP Network I give it some velocity to make it fall. After that I render the simulation with the GameDev Vertex Animation Textures Tool.
Importing it to Unreal. Setting up the shader but don’t getting the exact simulation.
It seems as if the pivot point is at the wrong place, or something. I’d appreciate if someone could point me in the right direction.

I attached some files from the Houdini network and the Unreal shader.

DOP Network in Houdini

VertexAnimationTexture in Houdini

Sim in Unreal


#2

Interesting, Before the export node can you plug a convert and then a transform node? Re-export and let us know.

I dont have anything ready atm to run some tests.

If that doesnt work maybe one of our sidefx residents knows. @luiz


#3

Thanks for the fast reply. After plugging in the convert and transform node and re-exporting it, I get even wearder results. The BBOX Max and Min values in Houdini are now set to 0 and the sim seems to be wrong rotated.

Also i get a warning at the vertex_animation_texture node, saying:
Warning
Skipping unrecognized parameter “png_alpha_multiplication”.


#4

I don’t think anyone has mentioned it but BBY and BBX and BBZ don’t work well with unreal from houdini. I know as i’ve used them to control some math in an asset i made recently. I made a lightning and i wanted to crop it in a curve path using BBY in my math i got the result i wanted in houdini but when i brought it in unreal it completely broke the curves i used. I used a uv attribute instead.

ps show us what it looks on an actual level not the preview window.
ps2 if nobody solves this for you try hitting up sidefx support, They will take a day tops usually to reply.
ps3 worth to mention my BB issue was related to houdini engine so it might not be related to your vertex anim export as i am not sure if it writes that info.


#5

Have you tried running your Unreal sim in a level at 0,0,0 just to be sure? In the material and animation editor windows you can have the floor offset. You could be getting the results you want, but the floor itself in the preview window is at -10 or something.


#6

Well, I tried all the stuff you guys suggested but without any success. It seems as if its because of the imported geo I’m useing. When I just create a tube from Houdini it works perfect with my setup. Even when I use the imported geo, but shattered, it works.
Always when Houdini adds some own geo it works. Do I have to use any special import settings for the FBX?


#7

Yo !
Have you checked that page ? https://docs.unrealengine.com/en-us/Engine/Animation/Tools/VertexAnimationTool/VAT_TL_Meshes
Theres a lots of infos on how to set up your texture and meshes.

Please note that I noticed that sometime you need to delete and create the VAT node because it can be glitchy.

Hope it help :slight_smile:


#8

Finally I found out what’s going on. In the Dopimport I had to set the Pivot Location to Origin.

Didn’t know that. It works now. Maybe it helps someone else. Thanks for your help guys.