When using Niagara Effect Type how can I override Distance Culling for a single emitter?

Hi I’m trying to get better at using Niagara Effect Type but I want a single emitter in the system to have its own Distance settings. Basically I’m trying to exclude it from the Niagara Effect Type, I don’t want it to be culled by Distance. I can’t seem to be able to override the NET in the emitter, here’s my RnD so far.


Basically setting Scalability to “Self” doesn’t seem to override the System’s or the Effect Type’s Scalability - and I’m not sure why this is happening, is it a bug? Am I missing something in my settings?

Alternatively the solution is to set the same individual scalability settings for each emitter in the system and only one of them having bespoke settings.

Ohhh my God I just realised… how am I expecting the emitter to last when the system is shutting down? [insert facepalm] scalability is working fine, I don’t think the emitter is meant to override the system :sweat_smile: