Vertex Animation output from Houdini


#1

Hello,

I was wondering if anyone has baked out a meshed fluid simulation within houdini into a vertex animation texture. If so any pointers would be great re texture pipeline, clamped vertex count and pipeline.

Thanks


#2

@luiz showed some of this off in the UE4 stream. While it’s doable now, I’d wait a week or two for the release of H16 where this seems to be added as a readymade tool.


#3

Thanks for the mention! Yeah, it’ll be here soon, but if you really want to know how it’s done here’s the shorthand.

For the mesh, scatter a bunch of tris based on the bounding box of the original sim, and make sure the UVs are built properly (the hard part)
For each texture, I’m making a grid which each face having the color information that I need and then rendering it out with Mantra with an ortho camera.

But yeah, if you can wait a little bit, it’s not too far off. And if you already have access to 16 via the AUP drop me a line and I’ll help you through it


#4

H16 is out…do you have a handy link to vertex animation tutorials?


#5


#6

Learning R-VFX on the Internet | A Tutorial Rant
#7

Yeah! That one too! Let me know if you guys/gals start playing with it and I’d love to work with you and see what you come with it


#9

Hey @luiz! Thanks for making these tools =). I downloaded your hip file and was testing this out on my machine and am getting strange results. If I open up the hip file for your cloth example and render from the vertex_animation_textures node you have it generates the position and normal textures correctly. If I drop down a new vertex_animation_texture node it seems to generate the normal texture correctly but fails to generate a valid position texture. Here is what the position tex looks like:

I see the vertex_animation_texture asset you have in the hipfile has been unlocked, and has an operator type of ‘vertex_animation_texture’, whereas the creating a new vertex_animation_texture node drops down a node of type ‘subnet.’ Any thoughts?


#10

Was wondering if you, or anyone, had any clues where I might need to check to get this working correctly. I’ve successfully gotten other fluid effects working in Unreal using the vertex animation export, but I’ve consistently gotten a jittery mess with this one:

Effect is supposed to be a solid with part of it melting away. Using shelve tools of “Melt Object” and “Heat Within Object” to achieve the effect and exporting using the method “Fluid (Changing Topology)”.

In Unreal I’ve checked Use Full Precision UV’s on the mesh, in the material put in correct values for Bounding max/min, checked appropriate normal_data/ pack_normal. In Houdini I’ve tried exporting many times with a variety of settings. Tried reading in different "Export Node"s, changing target polycount, texture size, equalizing edges… Still seem to get the same result.

Wondering if missed or forgot some important parts from the last time I created an effect from the vertex animation export.


#11

I think your framerange is off. If you think it’s 128 frames, try setting it to 127.


#12

That was actually my first thought, but I’ve messed with that as well. It’s entirely possible it’s something with how I built it in Houdini, as I’m still pretty new to it. Didn’t think I was doing anything too mind blowing, but I’ll probably try recreating the project and maybe exporting it at each step to see where and if it breaks. I’ll report back if I find something that’ll help save someone headache in the future.


#13

Are you using the Beta version from github?


#14

Houdini 16.0.633 and Unreal 4.16.1


#15

Yeah, but are you using the vertexanimbaker that comes with that version of houdini, or the beta version on Github?

The one on github solves a lot of bugs like these.


#16

Oh I see. Using the version that comes with Houdini. Where can I find the beta version?


#17

#18

Thanks! I’ll give that a shot with the original project and see if I get something different.


#19

Ok, so I feel like an idiot. For those who are as unfamiliar with Unreal as I am, when you have the mesh open and check “Use Full Precision Uvs”, simply hitting “Save” is not enough, you have to be sure to hit “Apply Changes” at the bottom of the section for it to take effect.

Thanks for the help @Partikel. Even though I was looking in the wrong places I plan on using this tool a lot so it’ll be helpful to have the latest and greatest version of it.


#20

Has anyone else imported the Rigid (Rigid Body Dynamics) version of this correctly in Unreal? I’ve done it successfully with the fluid setup but the rigid seems to have different material parameters and gotchas that aren’t mentioned in the posted videos.

For example, why are there 3 parameters for checking normalize data? Why are there 2 sets of bounding min/max values? If I apply the values supplied from Houdini to one set but not the other I seem to get closer (but still not correct) results in engine.

EDIT: FYI discovered the fbx being exported wasn’t applying the vertex colors to the mesh correctly. Some issue about the source mesh itself that I was importing into Houdini. The “gotchas” in Luiz’s videos are usually a good starting point for troubleshooting these issues. I might put together a short list for each of the export methods just for easy reference.

EDIT2: For some reason, in Maya, combining separate meshes in to a single mesh (freezing transforms and deleting history) doesn’t work for exporting the rigid method. Using a combined mesh as the source file that I’m fracturing in Houdini. The vertex animation texture export doesn’t assign the necessary vertex colors to it to read correctly in engine.


#21

Hey Guys I’m having some issues getting a rigid body into UE4, I followed the videos from Luiz but the export in unreal is a bit off as you can see… any ideas?

https://drive.google.com/open?id=0B19GnpEaIGHXQ1VDVzUxbUhHNTg

Update1:

with some tweaking its improved but still getting some strange rotation going on

https://drive.google.com/open?id=0B19GnpEaIGHXNGhUNS1NS3BqdEE