Vertex Animation output from Houdini


#22

Did you check this Parameter inside of your imported Mesh ?

I’m just asking, because I had some similar issue with fluid.


#23

the high precision UVs?, yeah I did


#24

It looks pretty similar to an issue I was having in the past. I asked Luiz about it and he had me get the latest version of the tool from GitHub: https://github.com/sideeffects/GameDevelopmentToolset/tree/Development

I think that had solved my problem (but introduced a new one I can’t remember) a while ago.

The problem, at least for me, that I had discovered was that combining meshes in Maya that were being used in the Houdini simulation, caused the tool to no longer write to the meshes vertex colors correctly on export. For the rigid body simulation the vertex colors represent the pivot point for a chunk of vertices. You’ll be able to see if that’s the issue by checking vertex colors on your exported mesh. If each chunk is a different color you that may not be the issue, but if the vertex colors are all the same (I think white) on the exported mesh, then that’s the problem. Either way getting the latest version of the plugin is worth looking at.


#25

Hey

Sorry for the late reply, getting the beta resolved the issue :slight_smile: but it seems to have issues with active and inactive regions, I will keep looking into this :slight_smile:
Thank you very much

https://drive.google.com/open?id=0B19GnpEaIGHXem85RTdrQ3VGWDg


#26

Hello !
Anybody tried usign (soft) vertex animation and normal map one the mesh ? I tried but I have no idea of what I’m doing.


#27

Hello! Someone else having the following issue with the “vertex_animations_textures”-node?

Using the RBD-method I get two bounding boxes instead of one called BBOX MAX1/MIN1. It outputs values when you render, apparently used for pivots but is never used within the UE4 shader. Using the values from the first set of BBOX-parameters makes the animation pretty much correct but sort of compact, with the chunks never reaching as far as it did in Houdini.

Here’s a screenshot of a super simple scene with a box just hitting the floor.
Capture

There’s and issue posted on Github for this specific problem here, but that was a while ago. https://github.com/sideeffects/GameDevelopmentToolset/issues/38

I’m using the latest update of the shelf and Houdini 16.5

Does anyone have a workaround for this issue? Should I just use the skeleton/joints workflow instead?
Cheers!

EDIT:

This being an issue posted on their GitHub got me confused; this is apparently not a bug at all.

With the correct settings for my specific case, i.e. unchecking “normalize” I managed to get it working.


#28

I don’t know if this thread is dead, but I think I’m having a similar issue.

I’m using the Vertex Animation Tool to export a large destruction animation for use in UE4. Unfortunately, on the first frame of the animation, most of the chunks seem disconnected and are just a little bit off. They don’t line up properly, so it breaks the illusion that the large structure is slowly falling to pieces.

Is there a way to make this more accurate? I have turned on full precision UVs in my models, and it looks like vertex color is exporting correctly (I think- at least, every chunk seems to have it’s own color). I’ve also turned off normalizing from zero to one. I thought it might be a limitation caused by the size of my geometry, but I’ve seen this problem on much smaller sims, too. Is there anything else I can try?

Thanks, everybody!
Brian Kohrman


#29

I found a solution to my problem. I needed to change my DOP import method to Fetch Geometry instead of Fetch Packed Geometry.

More details:
https://www.sidefx.com/forum/topic/55345/