UE5 niagara system scale does not account for emitter rotation

When I scale the Niagara system in Levels or AnimSequence Notifies, the emitters in the Niagara system are scaled separately. Has anyone solved this problem? If not, I’d love it if you could upvote the post below, this problem is driving me crazy.

Easiest way to deal with this is to make emitters local space, that’ll force them to take over the transform of their parents.
If that is not possible, you’ll need to get a bit crafty with transforms, essentially, undo any rotation that might have been applied, then multiply the scale by Engine.Owner.Scale then reapply the rotation to scale an element by the scale of the system

1 Like

In UE4 it worked with the rules you said when I made it emitter local space, but in UE5 it doesn’t seem to be the case.
Is there any way to define scale and rotation with those rules in the Niagara system?

Can you demonstrate that? In my experience localspace worked as expected in ue5

Really? I’d like to know how to fix this because if I don’t, I might have to revise 3 years of work. The first image is UE4. It’s the same system, but when I resize it on the parent actor in UE5, it behaves like the second image. I was wondering which version you are using. I’m using version 5.1.1.

I have that version installed, let me see if I get the same result

1 Like

You are very kind. Thanks you.

Damn you’re right, it only works at right angles.

update: you can see the issue quite well when rotating in a scaled local transform.

this is 1 full rotation


Please reply if you are able to resolve this issue. I’ll let you know if I find a way too.:smiling_face_with_tear:

Seems to me like a bug…
I guess your best bet is to do it yourself for each emitter… Like add some kind of scale parameter which you can adjust instead of relying on the global transform.
This way you have full controll over your effect and how it scales…

1 Like

It looks like the only way to resize the Niagara system is to do what you said. As you say, it seems to be a bug, so I guess I’ll just have to wait for Epic to fix it. thanks for the reply.