UE4 - GPU particles not casting shadows

I have a couple of problems here with my GPU particles.

How can I get them to cast shadows ? I have checked all shadow casting properties and they all seem to be enabled, yet still no shadows?

Also, why are they all so jittery? I need them to stay as GPU particles since they will be like shattered glass that comes to collide on a surface.

It’s buried in the documentation as an offhand comment, but GPU particles do not support shadow casting.


And I believe they’re jittery because of how GPU particles do collision. Since GPU particles can only collide against the depth buffer, and TAA jitters the depth buffer, so does the collision for GPU particles.

Thank you. I just read that about GPU particles not casting shadows.

You mentioned “TAA jitters the depth buffer” What does TAA mean?

Unreal’s default anti-aliasing technique, temporal anti-aliasing. They might call it Temporal Super Sampling, or Temporal Super Sampled Anti-Aliasing … I forget what people are calling it at this point.

It works by shifting the camera’s position slightly every frame then averaging the results. That’s greatly simplifying it, but the result is the depth buffer moves every frame in a kind of noisy jiggle.

I think they may have just recently implemented shadows for GPU particles, because when I turn on “Cast_Translucent_Shadow” for the light I see big blocky shadows appear.
The shadow map resolution is terrible but at least it appears they turned on.