UE4 color preview and actual color

Hi, I have some questions about cascade’s color.
I noticed that the color of cascade’s viewport and actual color in game view is quite different. I guess it is the lighting that’s making the difference, so is there any way that I can see the same color as game view?
It is quite a waste to go back and forth two viewports.
this was cascade preview,
and this is game view. When I turn on include lighting option, nothing changes.


That could mainly be happening for 2 reasons:

  1. Your shader is additive, and the background is messing up the colors.

  2. The shader is Default Lit and it’s taking info from the lights, thus, changing the colors.

Try setting the shader to Unlit! :blush:

oh well, it was unlit :sob:
is there any other setting that is wrong?

so it is suppose to look same everywhere I guess?

ps. I have tested with vfx apprentice project

6 7
the upper one is from my project, and the other is test set in vfx apprentice project.
colors are exactly same, but some how vfxapprentice’s one is brighter maybe it is material issue?

pps. I dont know if it is right place to ask, but about uber material from vfx apprentice it seems brighter than mine.

from this, the light part around is dark, because colors are actually dark there.

but in material instance with same texture, it became brighter!

sorry for so much questions :sob: it is so confusing

update : I figured out everything else but in cascade viewport, including and excluding light mode were both same
Is there any setting needed to include lighting in cascade?

as far as i am aware translucent materials will still be additive which is why your in-game view looks slightly brighter. might be worth trying out alpha-composite blend mode, should give you most consistent colour representation.

You can also try turning off auto exposure in you’re editor preferences as this will more than likely affect how your colours are represented.

1 Like

you can try to change the scene

1 Like

Lighting with default Unreal settings will always affect your emissive brightness/emissive color. The material being set to “Lit” will activate Base Color in the material. With Base Color, if the lighting gets darker, your particle will get darker, and with no light, it will be black. With Emissive, you could have no light, and it will be as bright as it is in Cascade, but if you increase the lighting, your emissive will also get brighter. If you have a strong color in your light, that color will affect your emissive’s color as well.

This artist covers how to get a more diffuse hand painted look in Unreal, and this setup helps a bit with light messing with your emissive values. The trade off is you can’t crank your emissive values up over 10 or so, depending on how diffuse your scene is, or else you get this weird grainy look to it, and if it’s too high, it will show inverted colors behind your particle.

You can also set your material instance viewer to use your scene’s lighting setup, so it looks much closer to how it will look in your scene/game.