UE 4.24 Niagara Ribbon Tiling

Hey,

I searched a lot and could not find anything in the internet. If you nice people here have an answer to my question or a link where I can find an answer, that would make me happy.

I tried making a flame trail in UE4 Niagara and unlike in cascade the texture is only stretching and is not tiling. Is there a switch anywhere inside niagara or what do I have to do?

Here is a video of my problem:

The ribbon has a velocity of 200 in Z direction.

1 Like

Check the Ribbon Renderer node, try playing with the Tiling Distance!

Jesus Christ now I feel dumb. I played around with it but only used small values. Thank you for giving me the energy to try it again ! :smiley:

Okay so that helped a lot. The tiling isnt a problem anymore but it seems like I am dragging the ribbon, like a snake. However, I want it to be like the second effect in the video where the ribbon stands still. Any idea?

Depending on how you’ve set this up I am guessing its particle lifetime.

It is basically the same ribbon effect as the second one in the video. It is the same lifetime. And it does not matter how I set the lifetime, the ribbon always looks like I am dragging it like a snake.

Right but one is cascade other niagara, so not same always :wink:
So how did you emit the ribbon? Just one emitter attached to a socket with a Ribbon Renderer? If you add a Sprite Renderer, do you see you particles floating…do they sit there or move with anything?

Did you use an event to make the Ribbons?

Well I started this one like the other one in cascade. There is a ribbon emitter and the spawn rate is set to 100. I do not want to have ribbons following particles, but one big ribbon going with the whole fire effect. I tried panning the texture and it helped a little bit, but this cant be the answer.

In the “Initialize Ribbon” node you should be able to adjust the Ribbon Lifetime in relation to the normalized particle age!

Well spawn less, for a shorter ribbon.
But I see your issue, is the cascade one using a flipbook?
You can use SubUVs, google it as others have written about it.

I am using “initialize ribbon”. But maybe I did not understand you well.
In the video first I show you how I want the effect to be and then how it is with this dragging. I also show the emitter.

no it is a tilable texture which is dissolving

ahhh that looks like a Local Space issue?
like you are pulling it along. again throw a sprite renderer and hide ribbon so you can see what the particles (that make the ribbon) are doing.

local space is off and the fountain emitter is doing what it should. I only have this “dragging” problem with the ribbon emitter.

Sorry not sure, have a sample scene to look at?

Cheers but i dont mean show the blue fire sprites, i mean add a sprite renderer to the flames and show what particles make the ribbon.
If you have a project to load I can have a look.

Sorry I missunderstoot you ^^’

https://drive.google.com/file/d/1Ip14bWSTy4MnxMlkS7GWII5EXV5x70cs/view?usp=sharing

A new project with the effect/problem.
And a video.

https://drive.google.com/file/d/1Ip14bWSTy4MnxMlkS7GWII5EXV5x70cs/view?usp=sharing

Hmm that is a weird one how it only happens when you move but I ran into similar issues before, sorry will have to look closer tomorrow. Have you tried 4.25? I think there was a UV tile problem in 4.24.

Someone else may chime in.

Good luck!