Translucency sorting order

Hi, so I am trying to workout a hologram effect, but I am having trouble with the translucency sorting order. I wanted it to look like in the picture, rather than see all the things below. Anyone know how to deal with this sort of thing?

Assuming you are using Unreal 4, Tom Looman has a great approach of archiv this effect by using the custom depth pass.

I used it a lot in our latest game and it worked like a charm.

Hope this helps


yup seconded - it looks a bit complex but it’s actually simple enough once you get your head around it.

Note you can’t write a translucent object to the custom depth buffer - so you need to have one that just renders to that and then one that is the hologram effect but he explains that in the article iirc.

This makes me a little sad. UE3 era had a single checkbox in the existing material settings to do this. :frowning:

Thanks for the replies! I got it to work with that article, but for some reason it seems to be working only as a Blueprint - there’s no placing an object in the scene, clicking Custom Depth and having it work. Or maybe I am missing something?

This methode needs one and the same object two times. The first one is the object with your transparent-holographic-fancy-whatever material and custom depth on, the second one is just a mask for the first one, it also needs custom depth activated, but “Render in Main Pass” needs to be deactivated, so you can’t see it. It just is a mask in the custom depth buffer. So if you want to place an object in your scene and activate custom depth and want it to work, you need a second object of the same kind, with the same transforms and, if their is any animation, this syncronized, and “Render in Main Pass” deactivated and “Render Custom Depth Pass” activated.

tl;dr: It’s easier in blueprints :wink:

Hi mr. pitz,

thank you for sharing the video!!! Tranparanzy and depth is always a topic!!!


Translucency now has a checkbox to write to custom depth so you don’t need the second mesh anymore.

1 Like

Oh, wow, that fixed all my issues with the Vertex Shader as well!