Niagara mesh renderer does not support SubUV?


#1

I am just facing a new problem in unreal engine niagara it does not support Subuv sheet with Mesh renderer check image what i am talking about…

if some one can tell me if there is any way to use subuv on a mesh in niagara it will be very helpfull.


#2

What would you expect that subUV feature would even do? Meshes are rarely unwrapped in a way that would make sense to it.

If you want something that scrolls along the uvs, just limit the size of your sample area and animate it using a value fed into the material (dynamic parameter, particle colour, etc…)


#3

i have this effect in cascade as you can see subuv that i am using on a curved planer mesh

same thing i am trying in niagara.


#4

to be fair it’s a parity thing. You can use mesh sub uv from UDK onwards in cascade, and it does come in handy.


#5

I use this a ton, especially for anime-style electric arcs, leaves, and muzzle stuff. It could be he’s not using the right texture sample in the material though, unless that version of Unreal combined SubUV and the standard texture node


#6

Oh, That’s probably one of those thing which isnt’ implemented just yet.
You can emulated that pretty easily using a material.

Something like this should do the trick.


@alex.underhill I thought cascade was migrated from udk? Is that not the case?


@Travis I don’t know if that is a bug or not, but in my experience subuvs on billboards work without acctualy using the subuvtexturesampler. That stops working once you started using meshes though.



#7

Yeah there are weird quirks between the two. SubUV won’t accept anything going into its UVs input, but it will use Cascade’s linear blend setting, and you can use both SubImage Index and SubUV Movie on meshes. The standard Texture Sample will accept UV inputs for distortion and such, and I’m pretty sure you can use Random on meshes, but Linear (or at least Linear Blend) will break when using it on meshes.


Niagara issues and help