Material Dissolve with Two Step

Hello I am trying to find out why whenever I use the Two Step node in my materials the Textures look pixelated. I am assuming that I need to make the textures bigger, I made them 500x500 pixels. Is there a better way to do this?
Screenshot (2162)

It’s beacuse your material is masked. So it’s much cheaper but not that accurate. If you want to avoid hard or pixelate edges - you can use translucent shading but it will be more expensive.

1 Like

Hello Musho!
Firstly: make sure that you use textures that are power of two 2^n (1,2,4,8,16,…128,256,512,…).
There are a few things the engine/renderer does under the hood which

  1. works better with power of two
  2. only correctly works with power of two (like automatic mipmap generation)

512x512 should be enough detail in my opinion. I recommend lowering it in the texture settings as a great way to find the sweet spot between visual quality and size.

So my advice: