Is this a Bug in Niagara?


As you can see in a video I’m encountering a very weird problem, if I use big numbers (thousands) in velocities and forces in a particle update the niagara system will look different in the level than what it does in it’s menu but when I start hovering quickly over any icon in ue4 ui then it seems to be quickly refreshing and look almost as intended and then it looks bad again when I stop doing it. Is this a bug or am I doing something wrong?

Hey, I don’t know what is this, it’s like kinda a bug but I think maybe it’s related to your scene that you place the Niagara system into your scene.
Try adding in blueprint actor as a component then gets the BP into your scene.

Do you have motion blur enabled?

Unfortunately adding this system to an actor blueprint doesn’t help.

I tried with and without motion blur and the effect is the same, I mostly keep my project without motion blur.

I thought perhaps it was a temporal aliasing issue, but if motion blur doesn’t improve it, that might not be the issue…

Are your particles writing into the velocity buffer?
Make sure that’s disabled inside of your material. You can also try ticking the ‘Responsive AA’ box (although I doubt it’ll make this better) or disabling the ‘Rendere After DOF’.
As @Niels mentioned, this looks a lot like something with the TemporalAA is going ‘wrong’. If you would want to double check if it’s TemporalAA related, you can just swtich to FXAA and see if the artifacts disapear. Sometimes these noise artifacts are just not avoidable when working with TemporalAA.

I just read your post again. And I think this is actually an Unreal Bug. But related to Slate. I have encountered similar issues when hovering buttons. I measured frame drops in the viewport between 3-10 fps when hovering buttons. You can enable the fps in your viewport and take a look, to see if that’s the case for you too. I assume the weird behaviour you’re seenig might be a result of this bug.