[HELP-UNITY] Alpha Clipping works on shader preview, but not on the effect itself

Gif link:

I’m trying to achieve something similar to this:

I’m aiming for an energy sphere explosion that seems dense, bold, heavy, THICK! I’m trying to go away from that thin “mesh/shelly looking” look

Any idea is welcome :pray:


Gif Link:

Alpha Clipping still doesn’t work grrr :expressionless:

PS: how to avoid those hard edges on th bottom, where it meets the ground? :thinking:

is there a Glow post process on? (or are you using fresnel that adds over the texture?) other than that I’m not sure I have enough to really figure out what it is doing , nor why.

edit this seems to alpha clip just like the preview yes?

you have to hide those seams manually/ artistically
soft particles shader approach i.e. a check against the depth buffer that will apply a fade based on intersection zones

I’m not sure what qualifies a “post process” (excuse my newbiness :sweat_smile:). And yeah, I’m using a Fresnel. I’ll drop an image of the Shader:

Hmm I think this is actually the Dissolve’s doing. The texture has these dark grey areas and, when it reaches the edge of the Fresnel, it gets more and more transparent as is gets “blacker”, right?

Dissolve working just fine:

Now the Alpha Clip:

I even replay the effect and I can’t spot any changes. I even cranked up the Alpha Clip value…

Let’s see how the Alpha Clip value impacts the preview on the same Shader:

Edit: In the preview I have the “Fresnel Color” HDR a bit higher than how it is set on the actual effect color gradient. This causes the center to be brighter on the preview in comparison to the actual effect.

PS: Big thanks for always coming for me, Torbach! I really appreciate it :pray:

unfortunately I have 0 VFX graph know-how because I’ve been in Mobile dev my whole career

the only thing I can guess VFX graph does nothing because it’s not attached
– to diagnose use your ‘alpha clip’ float / material without VFX graph - this way you can isolate if it is a shader issue or VFX graph issue

1 Like

Hmmm yeah, it does work when I create an Empty Game Object with a Particle System within it

That’s how it looks, notice the clean cuts:

I think I’m gonna mix the default Unity Particle System with the VFX Graph.

I need these values to be changed over the particles’ age/lifetime. I know how to do that on the VFX Graph, but not here :sweat_smile:

Do you know if it is possible?

yes custom vertex streams
Shuriken can have custom numbers/random numbers or graphs that talk to the shader and drive things that animate across the particles lifetime

i did a basic outline here

and here I found a video that breaks down what to do further for more uses and more vairables.

i’ve never tried to exhaust the custom data module, IIRC 8 is the max variables you can control

1 Like

Heeey I made it!!! :star_struck: :star_struck: :star_struck: :star_struck:

Still a WIP, but I’m definitely happy with the result I achieved tonight! Omg, I’m gonna go to bed so happy hahahaha.

Thank you so much for dropping this video!

1 Like

Can you elaborate a bit more on this? That’s what I’m currently tackling :slight_smile:

I’ve seen some samples on how to do it manually, but I don’t have direct info, i never used them for mobile

there are the simple settings for them built in obviously

maybe this too

afaik HDRP has 1 node that you use since it already communicates to the scene,
other than this i’m not much help

i think it might be as simple as choosing ‘lit’ shader and toggling the setting on… at least I think it might be this simple

Hey, Torbach, thanks for coming by!

I think my version might not support it or maybe it’s hidden somewhere else.

Here is what I did:

Right Click > Create > Shader > Universal Render Pipeline and created one each of the Lit versions: 1x Lit and 1x Sprite Lit

After that I created one Material from each Shader, which are the following:

Notice the Inspector Tab - it doesn’t have settings like the Documentation shows.

If I open the Shaders (Lit and Sprite Lit) through the Shader Graph, I can find similar settings to the ones mentioned on the Documentation. Here it is:


Sprite Lit:

Am I checking the right places?

i think the shader has to have it built-in and the check box is here on the material
this is using standard surface

so for URP

It says you have to enable the depth in the URP whcih I can’t for the life of me figure out however… there is no General settings to open in the URP rendering objects i’m in 12.1.5

all i can find is a new Universal render element and check the inspector

nor can I understand how to make a URP shader graph asset utilize it.

someone with more TD experience needs to chime in, SRP customization is pretty much outside my skillset at and the documentation is baffling with what i see in my current editor version

No worries man! You got me leaning on the right direction [I think hehe]

I started doing some reads and it was only now that I understood that HDRP is something “inside” Unity - a Package. I’m downloading it right now and let’s see if it’s gonna work well with Particles - I just HDRP related stuff isn’t that friendly when it comes to particles.