Vertex Animation Inside a Material - UE4 - [SOLVED]

Hey guys so I have a mesh with a material applied with the baked vertex animation across from Houdini.

All good so far, next I’m looking to spawn the mesh within Cascade’s particle system,

So particle system > new emitter > mesh data on > attach the mesh and material will follow,

But instead of getting the clean vertex animation mesh I already have it goes crazy and broken, my assumption is I may have to offset the particle to get it to work right? (but I have tried this quickly with no real result)

So my question is, has anybody spawned a mesh with a vertex animation shader attatched in a UE4 Particle system? and/or anybody got any tips on getting this to work


hi chris, I haven’t tried to use a baked vertex animation in a particle system yet but I’ll give it a go. Have you tried to convert your baked data from object space to particle space in the material ?

1 Like

Just tried and it seems to work fine without any space coordinates transformation! Here’s my material

This is based on vertex animation in the shader but not a mesh itself?

Ive got vertex animation on a material inside Cascade working, but cant seem to with a mesh and the material’

Ahhh good thought! ive tried toggling local/world space but otherwise wouldn’t no what to change to change it into ‘particle space’

Yes I’ve done this. In the shader, replace the object position node with particle position (assuming you are using the one from Houdini).

1 Like

Ahhhhh ofcourse, thankyou partikel hopefully works :slight_smile:

  • I actually don’t have a single object position node inside my material theirfore cant replace it with the particle position

So you didn’t use the shader code that comes with the Vertex Animation Rop in Houdini?

Yeah that’s exactly what I’m using :), heres a screenshot

Using the softbody method - no object position node being used whatsoever

I’ve only used the fluid version of particles, but if you zoom in a bit so we can read the nodenames perhaps we can help.

Ahhh, I could use that method but can be buggier than soft body from my experience if your topo isn’t changing as mine isn’t in this instance,

Ofcourse heres two more screenshots of the node tree

Have you tried adding particle position to the psotion? After it transforms to worldspace?

Yeah tried adding/dividing/multiplying the world offset by particle position, both in world space and in local before the transform over to world space - Maybe worth me trying with the fluid method!

Really appreciate the help :slight_smile:

Solved in the End! Thanks @Partikel and @gmartzloff , I tried using fluid export method across rather than soft body and made some tweaks and it worked :slight_smile:

1 Like

Then it sounds like you had an inconsistent pointcount. I’ve had that when I had a remesh or a bool somewhere in the network and when the mesh animated, it changed the count like once and it forked me :smiley:
Glad you solved it.

Yeah exacty that I think from looking at my old files I had! - ahahah yes something ill know/look for in future!

And for future reference anyone reading this as this did confuse me for half an hour;

If you are struggling to get the particle (with vertex animation mesh) to not constantly loop and correlate with the particle lifetime etc., swap the ‘time’ node in your material for ‘particle relative time’ which did the trick for me to sync it with my particles/lifetime etc. :slight_smile:

Thought id post here rather than recreating a whole new thread - I’m working on some ribbon like trails and have got the desired result in Houdini. [vertex anim across to Unreal] But regardless of polycount and increasing texture size etc. I’m still getting flickering and broken up lines inside UE4 (So instead of being a nice smooth curve/poly wire like line, I have a jagged or broken up lines at certain points)

  • I have tried making sure my texture filtering isn’t destroying the data needed,
  • Checked the mesh when polyreduced by the ‘vertex animation textures’ rop, - which looks all good to me in Houdini,

I just require a smooth result for the effect to work and currently having no luck, Please see the images attatched also, the smooth lines being what I have in Houdini, the black broken up ones the result in Unreal

Problem SOLVED

  • So I was exporting my position texture as a TGA rather than an EXR - the TGA files don’t have enough precision in comparison to a EXR - which fixed it :)!

[I thought 32bit TGA were equivalent to 32 bit EXRS but after some explanation from a friend I was wrong as EXR’s have 32 bits per channel rather than overall I think]