Unreal Sequencer - Particle Custom Parameters not working?

I’m trying to control the spawn rate of a Cascade particle effect in the new Unreal Sequencer, but I cannot get it to work. This used to work in Matinee.
I have created custom parameters inside the effect. I add a particle parameter track in the Sequencer, but when I click + I only see a little black box with nothing inside it. It seems as if it cannot find any custom parameters.

Does this functionality actually work?
Am I doing something wrong?
This is a tutorial that shows what I try to do in Matinee


1 Like

you need to make sure to expose the particle parameters on the emitter actor before it will show up in sequence iirc.

Thanks! That worked.
Another question. Can you expose for example Initial Location so that you could for example animate the size and shape of a box. When I do that I only get a x,y, z point that I can animate making it pretty useless.
Same happens for Initial Velocity.

sadly it doesnt seem so - you can animated vectors but if you set it to vector random to get a min and max then it doesnt appear in the sequencer to animate.

Yea that really breaks the usability a lot. I did a big list that checks what can be use in a good way. Lifetime, Size, Velocity, Location modules are all limited
Size and Velocity you can handle on the CPU, but I really try avoiding CPU particles since they are so slow. Lifetime there is no way to make it random, you could in theory have 2 lifetime modules but they are additive so you get pretty odd behaviours. Location module I can see no solution too.

On my last game we changed the engine to be able to send in custom parameters that we would remap with curves on the GPU, this worked great and is of course what you want.

On the bright side I think Niagara should be able to handle these parameters much better. I guess what we would want is remap a value like “Intensity” with a curve that is also multiplied with a random value. Do this for velocity, size, opacity, lifetime and you can do much more dynamic effects that can handle speed, wind etc well. I guess you would need to do special modules that support this behaviour.

Btw I like your tutorials, they are useful and well presented.
Best wishes,

I highly advise you to use Niagara instead of Cascade. It handles exposed user parameters much, much better.
You’ll also be able to change parameters in a more flexible way, as you can access more parameters and will not be as ‘limited’ as Cascade is.
I’m addition you have the option to use NiagaraParameterCollections, which is another benefit.
Takes a little bit of time to get into, but then you’ll never want to go back to Cascade ever again.

1 Like