Unreal Engine Niagara Box Position Incorrect works

Hello! I just try to use the box position module for spawn particles on surface only. And it doesn’t look right. Anyone have a solution?

Can you check a few things for me?

  • Does it still look like this when see it inside of the level?
  • Did you alter the box location module in any way?
  • What does it look like with surface only turned off?
  • What happens if you replace Particles.Position with Engine.Owner.Position?
  • On level looking same wrong.
  • no I did not change anything. This is origin module from UE4.
  • looking correct, as box with particles inside. Size changes works correct too.
  • Looking same wrong. With 3 expansions by 3 sides.

Surface Only Bands option - on higher values than zero particle roll back to box.

So, what if you filled in .01 in Surface Only Band Width?

no, 0.01 value doesn’t change anything (at least visually) - values close to box size just push back particles into original box shape.

I just made simple box location.
Not inherit Particle System rotation and incorrect works with active Local Space. But this is fit for my task right now.
As well I’ve reported to Epic about bug with module.

GIF

Niagara Module Script

I’ve got answer from Epic by my bugreport - issue in GPU sim particles. So on CPU it works correct.

1 Like