Unreal 5.2 Decal Question

This might be something simple… just not sure.

I’ve created a decal with the new 5.2 decal system for niagara.

The only issue is… the decal draws over my player character.

So basically if I have cracks on the ground and I walk over the “cracks/decal” they draw on top of me which ruins the illusion of the cracks.

Is there some setting either in the material or Niagara that turns off skeletal meshes?


You can open your character control BP and uncheck “receives decals”.
Similar option also exists in material details.


Exactly like Lee says, you can have pretty much any scene component draw into a decal stencil that opts them out of decal rendering. (including the niagara component itself)

1 Like

Thank you guys!

I’ll check it out.

Glad Niagara does actual decals now so you can omit them from projecting on things. I never wanted to use the faked decal method in UE4 because you couldn’t omit things without a handful of workarounds

1 Like

I don’t know if they have been added recently in UE5, but the latest NS properties have so many useful options like the custom depth, but it would be even better if we can do this on a per-emitter level.

Unfortunately that setting is on the scene component, so that’s likely not possible