Unreal 4.25 VATs have issues inside Cascade Particle Systems

Hey guys,

since updating to 4.25 my vertex animations (fluid) from houdini are not working properly anymore inside a particle system. They are animating correctly, but particle size & rotation modules are completely ignored. Exactly the same effect worked before the upgrade though.
Any ideas what changed? Is anyone else getting this as well?

Cheers

Hey @Priareos are you using the Material Function for fluid that you get when you enable all the Houdini plugin stuff, or did you do the copy/paste method for the shader from Houdini to UE4? I found that I needed to use the material function version to get it all working right, BUT I haven’t tried this out in 4.25. So, there may be something wrong, but I thought I’d mention the MF in case that’s the issue.

Otherwise, ping Mike Lyndon on the RTVFX Discord and he can probably help.

Heya,
just using the Copy+Paste material from the Vertex Animation Texture node.
So I was a bit suspicious and tested the exatct same mesh + material with Niagara. And it works in Niagara… which makes me think someone broke it for Cascade. I’ll try your method though, maybe the MF coming with Houdini Engine is different.

Cheers!

Same issue, really anoying !

Its a problem of 4.25. Bug i guess. Myabe its will be fixed in 4.25.2

It for sure makes it harder to migrate any existing Cascade projects to 4.25. I’m surprised no one else mentioned this anywhere…

EDIT: Just checked UDN, the issue is known & this is the workaround, if anyone wants to updated their project before the fix is in (target fix 4.26), without replacing all Cascade VATs with Niagara:

revert the changes done in 12558699 to MeshParticleVertexFactory.ush

1 Like