UE4 - Material Breaks when added to particle system


#1

Hello there. So i have this material I made to make a sort of flaming sphere that will be the center of a fireball I’m making. I made a mesh data type emitter in cascade and when I put the material on it Unreal starts compiling the shaders, then finishes and reverts to the default material. At the same time my material I made is now no longer compiling and is giving me these errors:

[SM5] /Engine/Generated/Material.ush(1670,9-53): warning X3206: implicit truncation of vector type
[SM5] /Engine/Generated/Material.ush(1690,9-53): warning X3206: implicit truncation of vector type
[SM5] /Engine/Private/ShadowDepthVertexShader.usf(129,2-33): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’
[SM5] /Engine/Private/HitProxyVertexShader.usf(27,3-34): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’
[SM5] /Engine/Private/LightMapDensityShader.usf(23,3-34): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’
[SM5] /Engine/Private/VelocityShader.usf(49,3-34): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’
[SM5] /Engine/Private/DepthOnlyVertexShader.usf(30,3-34): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’
[SM5] /Engine/Private/DebugViewModeVertexShader.usf(18,3-34): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’
[SM5] /Engine/Private/BasePassVertexCommon.ush(30,3-34): error X3000: unrecognized identifier ‘FVertexFactoryInterpolantsVSToDS’

This is my material:


Based on this: https://www.youtube.com/watch?v=MlLKqtfB1LQ (Sorry it’s in russian, if I helps I don’t speak russian either I just was looking for an implementation of something I had done in shaderforge and this was it)

If anyone could tell me what I did wrong to break this material and also maybe how to get it to work in the particle system next time that would be awesome.


#2

You have added yourself World Displacement/Tesselation and i think this is are not working together with Cascade. Instead you can use WorldPositionOffset for all Vertex Offset, if you what that as result.


#3

I tried what you suggested. It worked however I also needed to uncheck “Used with particle sprites” which got turned on automatically somewhere, as well as needing to check the override material checkbox in the mesh particle options in cascade, which I feel should be checked on by default. Thank you for the help!