UE4 Invisible materials still reflecting light


#1

Not sure if anyone else has found a solution to this… I’m working in UE4 to create a VR start screen/menu where the user is ‘floating’ in space. I have a spherical ‘sky’ mesh background and a plane and walls covered with an invisible material. I want to attach ‘star’ buttons to one wall to open various menu options (I want the stars to appear as though in the distance as part of the overall space area, hence the invisible walls). On another wall will be a ‘floating’ game logo/info.

The first image below is how it looks now. As you can see, the edges of the plane and walls still appear ‘visible’ due to the way the light is reacting with them and after playing around with various settings for days I still can’t figure out how to stop this effect. Resizing the plane to really small (since the avatar won’t be moving around) stops the issue with the floor, but then I need to get the walls to ‘float’ on nothing (and the walls still have the reflection problem anyway). Any ideas? I’m very new to UE4, so hoping I’m missing something very obvious and simple. I’ve watched/read countless tutorials, but can’t find where I’m going wrong.

The material settings (can’t attach a second image as I’m new) have Opacity: 0, Refraction > Material Expression/Scalar Parameter: 1.3.


#2

Ok, ignore me. I think I’ve found a solution with an invisible cylindrical tube ‘wall’! Now just need to get it to float on nothing without falling down with gravity! :smile: