Transforming actors during preview/simulation

In tutorials I often see the presenter select an Actor in the viewport and move it around or modify it after hitting “Play” to preview of an effect setup.

However when I hit Play, I only have the option of usual WASD gameplay control or mouse orientation, no viewport selection capability. If I Simulate, I can then select Actors but not actually translate them or anything with teh mouse and see the change take place dynamically.

I’ve checked around in the viewport, editor and preview settings in UE4 but cannot find a setting that that will allow me to do the same - I’ve searched the UE4 docs and general internet including the RTVFX forum but haven’t found an answer for where to allow this functionality.

Does anyone know where to enable that functionality in the UE4 editor?

Hehe, don’t beat yourself up… not sure its “documented”

Hit your windows key and you’ll break out of UE4 but it’ll still be running, then select Actor and do whatever.

:smiley:

Hmm, no unfortunately that just causes the Win10 Start menu to pop-up for me. Maybe it’s something with a Windows for Nvidia setting?

1 Like

Yes, then go back to UE4 and Select the actor in World Outliner… :smiley:

Hey! I’m not sure if the solution I have is what you are looking for, since it’s in editor. I use to have the same problem until I found a way to replay a particle system in the editor with a key. To do that, you just have to bind the key you want.

Go to Edit Preferences, Keyboard shorcuts, find “Reset All particle System” and " Reset selected particle system".


This is the result: https://streamable.com/bacmo5 (the effect is a burst, cascade and niagara works)

If not… well you could use Eject/Possess when you are in simulation (F8). With that you can move things while in Simulation.

1 Like

Thanks for the suggestions, HowardM and Anna, but neither has allowed the behavior I’m trying to find.

I should have posted an example the first time, but here is what I’m referring to in a JangaFX fireball tutorial. While he is playing back the effect in the preview, he selects the target blueprint actor and moves it around in the viewport and the blueprint FX setup responds to the new location:

If I use an ordinary Play->In Selected viewport, I cannot select anything in the viewport (I can in the Outliner with no additional hotkeys needed, but nothing in viewport changes). If I use Simulate, I can select the actor in the viewport, but it will not actually move.

I have seen other tutorials where the presenter select within the viewport (not outliner) to move things around during playback as well, but I have yet to find a setting that allows me to do the same.

image
you might be looking for the Eject button… The disconnects you from the current controller and “sets you free”. Then the Eject button change to Possess to take you back to the controller

Another alternative, which he use in the video, he use “simulate” instead of “play”
image

Ah jeez. Well, I discovered the solution and it’s embarassing. In the “Transform” attributes of the Actor, there is a “Mobility” parameter that is set to Static by default. Changing this to Movable finally allowed me to do what was shown in the video. I guess it’s obvious if you know that exists, which I do now :persevere:
moveable

Thanks for all the suggestions and bearing with me during this long learning journey

1 Like