The particle system in unity

Hello, this is my first time working with the unity engine. I wanted to practice creating a particle system, everything was going well from the beginning. Until I wanted to add HDR to the color, to control the color intensity. But after creating the shader, the material and their application in the particle system. My particles have become transparent, if you choose a texture without black color on the background, everything is fine. I don’t understand why this is happening, I ask for help. I attach a screenshot, problems. Thank you.
P.S I don’t speak English, I use a translator here. Please understand my possible errors in the text.

Examine the Shape module; removing the Default-Particle may help
The shape setting define location of emission, not the texture per-se

Particles are affected from this attachment
Default-ParticleClip Channel = Alpha
particle Color and Alpha are now affected by the emission shape, in terms of location.

Color Affects Particles :ballot_box_with_check:
Alpha Affects Particles :ballot_box_with_check:
I believe you want all of that removed.

Use default-particle in the Renderer portion as the texture for the particle, and remove it from your Shape settings

1 Like

Thank you, it really helped me! Hot and the ability to change the color intensity remained only through the shader, and not in the inspector at the start color point. Maybe in the future I will solve this problem. Thanks again!)

You can change intensity sith PSystem via custom vertex streaming I guess.

Maybe, but I don’t understand all this yet, so that I can make custom implementations of something.

You cann add texcoord node to the shader (texcoord.xyzw, doesnt sure about name of this node in shader graph. And use teexcoord.z for multiply emission.
Then activate custom vertex streaming in render module
Add custom with channel counts that you need.
In this case you need the single one.
You can see here TEXCOORD0.z (that means you will use Z channel of UV0 set).
Then activate and add custom data

You can use whole texcoord node, but you must be sure you added it in custom vs right. At first add custom.xy, sou you will use all TEXCOOR0, then add custom.xyzw, so whole of it will use TEXCOORD1.xyzw. Then delete the first custom. A little bit awakward, but still more comfortable to use in future.

And then just choose color in custom data

Don’t forget to switch UV set for TexCoord node from 0 to 1 (TEXCOORD0 to TEXCOORD1)

First solution is for emission, the secon one for the whole color.
But be sure you using this shader only with particles AND custom data, because if you dont - this node will always give you ZERO multiplier. Or make switcher for particles (with using additional data), and without (multiplier = 1). Hope it will help.

Very usefull thing. You can change any shader parameter you need for each particle.

Thank you for such a detailed solution to my problem! I really appreciate it, and soon try your suggestion :grinning:

P.S Anyway, I don’t have enough experience yet, I can’t implement your described option. In the future when I become more experienced I will try to implement it

1 Like