Sunfire Cape FX problem

Hello people,

This is my first post on this forum and i’m new to the realtime VFX train. I’ve been reading this forum for a while and started to make some FX using the knowledge gathered from here, so thank you first of all! :slight_smile:
I’m watching Jason Keyser’s videos and im trying to make a Sunfire Cape effect in UE4.
I’m having trouble making the Cape effect pause for a bit and not go non-stop. I saw that when my texture is panning it is looping from the top, or simply put when the textures goes to the bottom its starts to show from the top.
I painted the texture so it is seamless in the horizontal axis, i didn’t expect it to loop on the vertical.
Can anyone explain why is this happening?

Thank you all in advance! :slight_smile:
net-gifmaker (1)

You probably want to clamp the texture in one of the axis so it doesn’t wrap around. Double click the texture asset in UE4 and look for this:
2018-03-21 17_33_42-

Hey Bruno, thanks for the reply :slight_smile:

I did try that but it doesn’t seem to work. Its squashes the texture if i clamp it in 1 axis.

If you watch Jason’s video, his texture scrolls down, and after a while it starts to show again from the top. Mine starts to scroll from the top the moment the first time it goes down. Maybe its something with the UV?
ss3ss4ss5

I’ve been reading and the only solution seems to be to clamp the texture, but I cant make it work.
If the texture is clamped, do I need anything else besides a panner node?
I want to use this as a mesh emitter in cascade, so the texture would have to start scrolling for each particle in its relative time.
uess

You need to add an offset for your to your UV Coordinate. Russel talks about this in his Soulercoaster thread VFX Basics - Mesh Soulercoasters. I believe Jason is using the same technique for Sunfire Cape, but I could be wrong

Clamping is the correct thing to do, kind off, since panners are using time to offset your texture however, you are sampling way outside of the clamped texture bounds.

Clamping will make every texel outside of your 0 - 1 range sample on the closest pixel inside the range, that’s why you get that stretched out looking artifact.

You might be clamping in the wrong direction aswell :smiley:

I suggest leaving the texture tiling method on tiled and using your shader to clamp to the appropriate region while debugging :smiley:

Thank you for your help, it worked! :smiley:

I used the method that Travis posted. I figured i need to do it that way, but couldnt get it to work, but now i see its simple. This way i have control over how it scrolls :slight_smile:

@Wyvery i tryed every way of clamping, and the results was as posted earlier or it didnt show anything, just empty texture.

Can still upgrade the timing and the textures, but for the beginning i’m happy it scrolls the way it should :smiley:

cape02

1 Like

So you got the desired look you were going for?

Yeah, im not 100% happy about the textures, but atleast now i can do the tweaking correctly since the shader is working. By using the dynamic parameter i can control how fast and when the texture is going to scroll. Thank you for the post again! :slight_smile:

I would like to get some critiques on this, since im a begginer still :smiley:

Glad you got it figured out :slightly_smiling_face: