[SOLVED] VAT dynamic remeshing not generating rot & pos texture

Hello everyone!

I’m working with a fluid simulation in Houdini that I want to bring into UE 4.27 but I noticed that the VAT tool is not generating position or rotation textures for dynamic remeshing method. It’s only giving me the mesh and a lookup texture. Any ideas what could be happening ?

Rigid body dynamics and Soft body transformations seem to be working fine thou

Do you know if VATs supports that workflow? Though I haven’t confirmed this, I’m guessing VATs require a constant geometry topology (i.e. the points can move, but the number of points and their connectivity can’t change). If you’re remeshing, that re-creates the topology.

Can you post more details? I’ve used VATs successfully from Houdini; but, I’m not quite sure what you’re doing in this case.

It does support dynamic meshes…I was trying to recreate that old VAT tutorial by Andreas Gladd where he creates a fluid sim and uses VATs to bring it in UE…
Anyway I found out what’s going on:

image
image

You have to render the first pass to generate the mesh and lookup texture and then render the second pass for position and rotation maps…
This seems to be the pipeline for the tool in 4.27

My new hurdle is that even though the materials and textures are working by themselves, it seems to be broken when trying to bring it into a particle system be it niagara or cascade :confused:

1 Like

Interesting… I never noticed that “Second Pass” option in there before!

On the Unreal side, I assume you’re using the material which is part of the Houdini plugin? And the matching version? I once had a version mismatch between the plugin and what I used to export from Houdini.

Hey rhorseman. I am not sure if you have figured it out, but I had the same issue and it’s because they have a different workflow in the new VAT3 version for particle instancing. You can find the workflow here > https://www.artstation.com/artwork/zOyke6 under the Instancing, Mesh Particles and Legacy Parameters section. You basically check Support Real-Time Instancing under the Advanced tab and if you follow along with their workflow you will be good to go :slightly_smiling_face: Also, if your dynamic mesh is all blown up in UE and you have everything setup correctly, then just restart UE and it will work properly. I don’t know why, but it works. Hope this helps!

2 Likes

wow thanks for this tip!
I just tried it and it worked ! At this point I had almost given up hope ! lol

Awesome! Glad it worked out.