RBD to FBX spazzes out for small pieces

Hey folks,

Coming over from the world of film, I’m trying to get myself up to speed on realtime fx during the downtime I have, and I’ve found something that’s tripped me up.

I’m trying to work through the process of getting a rigid body sim into Unreal, as an fbx. No matter what I try, however, the small pieces of the sim that are moving quite fast seem to go crazy as soon as the collide with the floor.

I imported the same file into Maya, and it all seems fine.

As far as I can tell, all of my import options seem to be the ones that are recommended:

I can’t for the life of me figure out what the issue is here, so any help will be mighty appreciated!
Thanks!

Could be a ton of things unfortunately.
What’s the bounds size of it inside Unreal?
What does the Skeletal hiearchy look like inside Unreal? Kind of looks like the smaller pieces are picking up a parent’s transform too but that might not be the case.
Its unlikely but it could be animation compression going to town on it inside Unreal. I wouldn’t have expected it to be the case but if the scene’s super large or super small it could maybe be a factor.

Hmm, have you used Houdini for that effect?

You can try reduce the amount of pieces or delete those pieces that goes crazy and do your own debris.

I don’t know what is causing that problem, but if this is something you plan on using in a realtime setting (games etc.). Like Bornikus mentioned, I would just reduce the number of fractures and just keep the big chunks in the actual simulation, the smaller debris is easy enough to set up inside unreal using sprites. For fracture sims you’ll never be able to tell if the small debris is sprites or not when coupled with smoke etc.

I probably will reduce the number of pieces when I move on to the actual project I’m doing, this was just a test. I did another test with fewer pieces, and everything seemed stable. Although I’m still curious as to what the issue with this is, just so I can avoid the problem in the future. Is there a golden number for how many pieces Unreal can handle?

The size of the animation doesn’t go above 13x13x13, which I assume are Unreal units. The hierarchy is world_root>TRANSFORM_NODE>piece#, which is from the RBD to FBX node from SideFX Labs.

All I could think of was that maybe the way the pivot is being read is what is causing the issue, but I don’t see why it would only happen to the small, fast moving pieces.

A bit late maybe you solve it but your problem is the interpolation type inside the animation @Caffeen
By default unreal is interpolating all the key frames and is fucking up your SIM. You need to change the interpolation type and all will look good.

1 Like

Aha! Thank you! Very good to know what the issue was for the future. Turning the interpolation to step along with removing frame stripping fixed it. Thanks again! :smiley:

1 Like

Hi! I have the same problem. I have found “interpolation”, changed it to “step”, but I cannot find “removing frame”. Could you direct me, please?