Question(UE4 Niagara) : How do I set the mesh to align in the direction of velocity(Move direction)?

I am a student studying in South Korea.

I hope it is in the same direction as the ribbon emitter used by the mesh emitter.
(This mesh emitter is with the ribbon emitter)
However, it does not work properly on certain aixs.

Honeycam 2022-10-12 03-51-45
[good case with x&z aixs]

Honeycam 2022-10-12 03-52-17
[bad case with y&z]

[ The result I want ]

(current setting)



image

1 Like

Since you’re hard coding the “Side Axis” to be (0,1,0) this means that whenever you move the particle system along the Y axis it’s velocity will be collinear with its “Side Axis”, and since the mesh can’t both be looking towards Y+ and be sideways towards Y+ it will end up doing something weird like that. There’s probably something similar happening whenever you move the particle system along the Z axis since that’s your hardcoded “Up Axis”.

The UE5 Niagara Modules for mesh orientation are different to the UE4 ones so I’m not sure if this might be the reason, but having multiple of these 3 constraints in the module checked at the same time might be what’s causing issues… Try unchecking the “Side Axis Direction” option or the “Up Axis Direction” option or even both, and see if that makes any difference.

3 Likes

Thank you. I didn’t think about turning off both options, but I turned off both options and it was resolved.!!!

2 Likes