Opaque textures in vfx graph

Hey guys!
I have a pretry newbie question, but I can’t find an answer for it.
Recently I’ve been venturing into vfx graph, I’m trying to make an impact smoke, similar to this;

So far I have this,

I want it to be opaque thought, right now I can see through the texture, I tried switching the blend mode for opaque on the output, but then I got this;

Anyone can give me a tip in how to achieve that?

1 Like

Hi there, using Alpha Clipping and adjusting Alpha Threshold will make that sharp cut edges you want.

Otherwise your option is Alpha blend, not Additive.

image

If you did that and your texture is still black as on the pic you sent, it doesn’t have a correctly setup alpha channel. You can either do it by hand or try using grayscale as an alpha source in the texture import settings, but that might not give the best results, depends on the texture :person_shrugging:

image

1 Like

Oh! Thank you very much for the answer! It actually worked very well.

2 Likes