Niagara Help: Particle Light Properties & Random Emitters

Hey guys,

is there a way to access the light settings (e.g. shadow casting, volumetric shadows, volumetric scattering intensity etc) for particle lights? Are they not normal point lights?
There’s only very few settings within the Light Renderer and I’m not quite sure how to alter it or access it…

Side question: Is there an easy way to randomly activate only one emitter from multiple emitters within one particle system? Like picking only one emitter by random chance every time the system fires.

Cheers!

Just in case anyone else encounters this:
Since UE 4.26 you can add a Custom Renderer, e.g. a Point Light. You can then tweak all setting to your liking. This seems to be super experimental though, just as a warning.
Take a look at this guys post on how to set it up:
https://cultrarius.github.io/UE4ParticleEditorPlugin/tutorial.html#light

I was looking for this issue too.

Cascade Light render will fade away along with particle lifetime, but in Niagara Light renderer the light wont fade away along with particle lifetime, it just turn on and off when a particle dies.
I’m looking for a way how to make a niagara light fading setting along with its particle lifetime.

Scale color over time 1 -> 0

I tried, the particle sprite renderer does fade away, but the light renderer just turn on and off in a frame.
Currently I create the particle material with sprite renderer to act as light, but I just wonder what if I need real light to emit the light to surrounding object.

The particle light module takes it’s light strength value from particles.color, if you set that to 0 it shouldn’t be able to emit light.

Can you show your setup?

https://imgur.com/a/ rtGPaWY
(please remove the space between in case the video not showing)

Left is cascade, Right is Niagara.
As we can see, left side light is fade away, but the right side light is just on and off even the particle is fading away.

and here is my light renderer setup

1 Like

You need to set rgb to 0 as well I think.

Just tried that and it’s not work too, light renderer still wont fade :frowning:

Could you show the inside of the light renderer module?

Sure, here it is.

Could you remove the color add?

I don’t think it will take effect, if we remove color add, the glow doesn’t visible enough, but I will try and let you know the result

You can compensate for that by increasing the particles.color to a higher brightness.

I made it work by converted my cascade setting to Niagara and found this Attributes, then Increase the attributes from 1 to desired number to make it fading.
But I can’t find it on User Attributes System tabs, do you know how to make this attributes? ( I’m trying to see what inside but it cannot be double clicked )

1 Like

If you set the parameter in the stack, it should automatically get created, there should be no need to then also manually add it.

If you do want to manually add it though, click the + button next to Particle Attributes and type float, then type the name (LightExponent) then enter to create it.

Light Exponent is the exponent used for the exponential light falloff. It makes the profile off the light different with respect to distance from the source.

2 Likes

So, I was curious and investigated this. It seems the Light-Color relationship is just a bit weird. The scale of the color needs to be super bright to have an effect, the Alpha is being ignored. The easiest workaround would be, to create your own LightColor parameter, into which you can feed whatever values you want to affect the light. Then you bind your custom LightColor to the Color parameter inside the LightRenderer. This is how you can do it:

-Create custom Linear Color Particle Attribute called ‘LightColor’
-Set the Attribute in the Particle Update to the Particle.Color multiplied with a high value (this would be your ‘LightIntensity’, in my case 50000). Multiply this with the Alpha of your Particle.Color (if you want he Alpha to affect the light color)
-Assign the LightColor attribute to the Color Binding inside the Light Renderer
-Then your Particle Color nicely affects your light & light intensity (via Alpha). You can tweak the general brightness of your light as well (by adjusting the multiply value)


3 Likes

This helped a ton for some issues, i was running into today. Thanks for the post!!