Niagara Emitter life cycle in unreal 4.27 not showing(?)

Hello there, I’m new to VFX and specially with unreal, I’m doing the Gabriel Aguiar course but he uses the unreal 4.24 and I’m using the 4.27, so in the Niagara System when he chooses the emitter there is a “Emitter Life Cycle” panel at the Emitter Update, in my Niagara system there is no life cycle panel just a Emitter State panel.
The problem is that at this panel I don’t have a “MaxLoopCount” if I change the loop behavior I get a pretty similar result to the one in the course but I’m not sure if it works the same way.
If anyone knows if I can get the Emitter Life Cycle parameter or how to achieve the effect to work the same as the Life Cycle does (or if I’m doing it right changing the behavior to “multiple”) it would help me a lot. Sorry if it is a dumb question, I’m really new to Unreal.

I’m not totally sure but I think you have to change the loop behavior from infinite to multiple and then you can select the loop count.

3 Likes