Niagara collision question

hey guys i want the collision particles to only work in the background in the game, excluding the character

So I tried changing several options of collision in Niagara,

I couldn’t find any other solution. How can I solve it?

Depends on the type of Emitter & Collision you want to use.

  • CPU emitter will be raycast collision (expensive). You can specify which objects to collide with in the Trace Channel. Just select ‘WorldStatic’ and not ‘WorldDynamic’ and it should not collide with your character.

  • GPU emitters have other (cheaper) collision options. So a better method would be to use Distance Field Collision (Distance Fields need to be enabled in the project settings).
    As only StaticMeshes have Distance Fields and SkeletalMeshes don’t, your particles should only be colliding with your background objects and not with your character.

1 Like

cool, it’s really work fine thx!