Issues with ribbon moving towards camera

Hello! :slight_smile:

So I’m making a game with a group of friends and I’m doing the particle effects. I’m pretty new to ue4 and cascade and I’m having a bit of a problem with creating a nice weapon trail effect. This is what I have right now

We will make the particle effect only be visible when in attack animation through Blueprint. My problem is that I want the ribbon emitter to only trail in the X and Z axis. But nothing I change seems to achieve that, I’m really confused why the lock axis component seems to do nothing. It doesn’t matter what I change in there, it has no effect whatsoever on the emitter.

The particle is atm a component of the weapon .fbx. Here’s an Imgur album of my emitter settings: https://imgur.com/a/d7i63ag

I didn’t include color over life cuz I don’t think that has anything to do with this problem. I have also tried with an Animtrail emitter but then I had a really weird jittery effect that happened when you were jumping and attacking at the same time :confused:

Hi Hampen, and welcome!

I think that the problem you’re dealing with is connected to the particles using world space, while they should be using camera or player space.

In Unity you can set a custom simulation space and assign the camera transform to it, but I’m not sure if you have that option in UE.

Hi Hampen, look into using anim trails instead of the ribbons. Here’s some more info: https://www.youtube.com/watch?v=5HkghxEIXiU
With the anim trails, you can easily specify two sockets to stretch the trail between, and you can add them on the animation track, instead of activating via blueprint.

I’d start there, and if that doesn’t solve your problem, then I’d suggest building a custom mesh with a panning material - takes more work to set up, but you can get some really nice results with it.

Hi, apologies for the slow reply! I tried the animtrail approach and it looks decent, however, I have one issue, when the character is standing still or moving back and forth the animation looks exactly like i want it to look, but when you are jumping up and down the trail looks like a lightning bolt for the lack of a better term, these are my emitter settings: https://imgur.com/a/OQw9iTg

and here is a short video showing the issue: https://streamable.com/jamdfn
(applogies for the red debugging thing, my programmer is working on the attack logic and needed to do some debugging and i have no clue how to turn that off as of the latest commit :sweat_smile:

I assume the issue has something to do with Source Movement, but if i turn that off then the trail doesnt follow the player (tried with both localspace on and off)

Yeah, if you need the trail to look about the same regardless of player movement, I’d build it out of a mesh and animate the material… If you search the forum for trails you’ll find a bunch!