Is there a way to enable an sub emitter (burst) for evevy hit, inside a Niagara system


I’m trying to figure out how to enable an emitter (burst), for every subsequent hit. Instead of using a specific Niagara system for the hits effects, I will have only one system where I can trigger the burst emitter inside. Let say a simple system with 2 emitters, a shell and a burst effects… Was thinking using an user parameter inside the Spawn Probability to trigger the Burst effects or using a bool, both way I wasn’t able the trigger it. Am I missing something because it’s not that complex?

Hi! You should be able to do this by setting the loop behaviour of your system to be infinite and having a small loop duration, that way it will try to trigger the spawn burst frequently and eventually do so when your parameter for the spawn probability is true, like so:

However I don’t think this is the most optimal solution since the emitter is going to be updating constantly trying to spawn the particles. But it might be the best, depending on your setup. Hope it helps!

Thanks for your answer, I did tried the same thing yesterday. Like you said it’s not very optimal and not very precise.

I’ve been thinking about this in my free time cause it’s something I’ve stumbled upon before, and I think I found a solution that’s both accurate and pretty optimal.

The idea is to create a float parameter that when the trigger condition bool is true, sets the spawn time of the emitter to the next frame using system age and delta time, sort of like this:

While the trigger condition is false the spawn time is a huge number that will never be met (or a specifically set max time), and when it’s true it sets it to the next frame time. You also need another bool parameter to know if the emitter has spawned particles already, otherwise the next tick the system will update the spawn time again to next frame, and over and over again and it will never trigger.

Thanks, I really appreciate your help. Wow it works! On the other hand I don’t know why it only works for the first shot and not for the other subsequent ones. :smiling_face_with_three_hearts:

1 Like

by increasing the Loop Duration it seems to work. thanks to you!

1 Like