How do you remove seam lines in meshes using vertex animation textures? [SOLVED]


I’m using vertex animation texture to export a rigid body simulation from houdini into UE. But when I bring in the assets to the engine I noticed that even at frame 0 there’s visible seam lines where the mesh was cut in houdini.

The material and material function seem to be working fine as I see the pieces matching their behaviour in houdini. Is there a specific setting that I need to change either at export or import for it to display without those seam lines ?

I dont specifically remember the exact setup, but it has to do with you normals. You should either transfer the normals from your initial mesh or play with the settings to get similar normal on your destruction mesh.

The other solution is using two meshes and swapping between them. That’s how I’ve seen it done it production.

1 Like

when the budget allows for it, and I am allowed to be lazy, I just overlay the regular non-cut version over the cut-up version and mask out pieces where it breaks.

In most cases this is for shards of glass/rock/ice so I can just “flip” between the regular and shattered one, or get away with a simple gradient fading away the regular one; showing the cut-up one (falling into pieces) along the way.

thanks for the replies! I appreciate it

Unfortunately I’m trying to be as efficient as possible for this asset as it would be an object that’s always in game and activates the animation on interaction.
I thought about swapping meshes but that also risks of skipping/clipping when loading :confused:

I wonder if I also have to manipulate the UVs in a certain way to avoid the lines…

A little bird told me a new VAT coming - . Stay tuned for the announcement on GameDev HIVE on July 7th. :smile:


1 Like

I had the same issue with VATs in Unreal. In my case I didn’t use a Time node in the material but a scalar parameter to make the simulation progress. And to fix this kind off “offset” in the sim I had to start with a negative value of -0.02 or something like that instead of a starting value of 0.
Maybe that helps you :man_shrugging: :crossed_fingers:


So I actually think I have found a solution for my case and that is just making a switch from using the displacement that controls the vertex animation; turning the displacement to zero eliminates the seam lines completely so I just make an if statement to switch immediately to one as soon as the timer variable sets off and then it just moves on as intended.

pardon the spaghetti