Help with panning a noise node on the y-axis (UE4) (Solved)

Hey all! First time posting here. Only just found this site and i am already super inspired by what I’ve seen. I am new to this scene (coming from a programming background) and looking forward to learning more.

I have a question that i hope is going to be nice and simple to answer!

I am trying to pan a noise node on the y-axis but i cant work out how to do it.

This is my current setup showing both attempts.

I thought that i could just drop the X part of the float and that would cause it to only pan on the y-axis. But dropping the X value seems to lose me the noise like so

I would like to keep the noise in the tops nodes but have it pan like vertically like the second set. I have tried a number of different combinations but cant seem to get it right.

Would anyone be able to give me a hand please? If you have any questions or want to see more of the graph let me know.

Cheers

Hi Nexidian,

Have you tried linking the X node to a float with a value of 1 ?

Hey Tayko! Yes i have i tried that but the noise still seems to only generate horizontal lines

Hey Nexidian, you still have to connect the x out of the the panner. Control the direction by setting the speed in the panner node or by appending two scalars to make your own vector, that might make it easier to control.

It didn’t work because the panner node doesn’t output a single scalar but UV coords.

Alternatively, you can skip breaking out a float3 and time dilation. Make your own panner by multiplying your speed vector with time and add that to UV coords, then append a 0 to make your float3.

Hey @Pumpking thank you for the response and sorry for the delayed reply i had to step out for a bit!

Thank you so much for this, it seems so simple now i’ve seen it! I had tried plugging in a scalar value for the X in the hopes it would fix that but i didnt fully understand why that didnt work.

I thought it was interesting how the breakout function supplied R and G channels which would work fine, but supplying scalars didnt, i guess this is because as you mentioned!

fire

Thanks a lot for this! I really appreciate it

1 Like

You can break this down even smaller if you wanted to. You just have to remember that R and G are X and Y respectively, but you can use float 3 parameters, and that will cut your parameters in your material instance down by half. In the image I added, I have my pan speed going at 1 on X just to preview it, but you can leave those at 0 by default.

1 Like

Its not work in UE 4.23 Please help

Hmmm, this still works on 4.24. Are you using the default values in your Panner, TexCoord and Noise node?

Alternative setup