Help! Ribbon Emitter issues in UE4

Hi All,

I was wondering if anyone here could help me with a problem. I am blocking out the movement for an Arcane Missile (hearthstone) type effect and I seem to have hit an issue with the trails for my particles. (video of the hearthstone effect here

In cascade, when I rotate the emitter, everything is fine, and all particles behave normally, including the ribbons. However, when I switch to spawning the effect in a level, the ribbon trails do not follow the rotation I set for the particle system in the blue print. All I am doing is setting a random rotation on the y-axis using a float selected from a random range. In this case -75 degrees and 75 degrees.

What is happening is the ribbons are spawning correctly in the original rotation, but are not following where the particles actually are. See video…

Does anyone know how to fix this? or perhaps know of a better way to do it in cascade?

In this video you see the particles following the randomized rotation, but the trails staying at a rotation of 0 degrees.

In cascade the ribbons follow emitter rotation fine (when I record they go a bit mad but it should show them well enough)

Thanks for any help any of you can give! :slight_smile:

Hmm interesting. Have you tried making the trails child particles to the bits that you want them to follow? That might be easier than trying to rotate things independently.

The trails are emitters within the same particle system as the particles they are following, with the parents particles set as the source. I figured as I am just setting the rotation of the particle system at spawn in blue print that that would affect all emitters within the particle system… it seems like it is only affecting the parent particles though… which is odd to say the least…

I am trying something else to see if I can get that behaviour I want some how… I have a feeling this may just be an issue with cascade…

I ran into this same problem a while ago. It seems to be an engine error. I sent Epic a bug report a while ago and they said they’d be looking into it.

From their response:
“It seems that ribbon particles ignore rotation entirely and when translating act as though they are in world space if you check” Use Local Space". Red = CPU and White + Ribbon Types. The top left test isn’t very clear from the screenshot but the red particles rotated around a fixed point while the white particles stayed in place."


So… my work around for this… I have no idea if it has any real world application, as I have no idea about budgets etc perhaps you guys could enlighten me?

I made 4 copies of the particle effect (so 5 in total) and then set the emitter rotation of each one in cascade to 30 degree intervals (-60 -30 0 30 60). I then created an array of those particle systems in the blueprint, and then pick one to spawn at random.

This basically fakes the randomised spawn rotation, as you are just picking randomly from 5 presets. I also set up an array of 8 targets (mimicking a full enemy set up on hearthstone) just to test the affect when fired at varied targets. I was pleasantly surprised. Now I can focus on actually making a nice particle to go with the system :slight_smile:

All in all it does the job but I doubt it is very efficient though :S

1 Like