[HELP!] Artifacts showing up when Scrolling Texture on Mesh

Hi hi! Had to pause my VFX journey but I’m back!

So, I want to make some kind of slash effect and wanted to control the motion by scrolling the texture from “outside” the mesh, like so:

The issue is some artifacts are showing up when the texture is “out”. Plus, the artifacts change in a glitchy way depending from what angle I look at the mesh.

This is the Mesh I’m using:

This is the Texture I’m using:

Edit: Wrap Mode is set to Clamp

I also experimented doing the following on the Shader:

Hi there. I’m pretty sure it’s because of the Mip-Maps, so first thing I’d do would to setting Border Mip-Maps on both textures, if that doesn’t help try disabling mip-maps just to see if that is even the problem.

If it is then this post from bgolus will have some answers Need some help with strange lines - #2 by bgolus

2 Likes

For this particular case, another solution would be to explicitly black out any area outside of the 0.0 - 1.0 range of the UVs in the shader. In shader graph you can use the Rectangle node to accomplish this.

1 Like