Flipbook on Beam Emitter

Hi!

I know that subuv’s don’t really work with beam emitters, but I figured I could at least create a material that uses a flipbook. However, it appears that each texture tile is on a different frame of the flipbook. Any ideas? Or should I use a different technique?

Thanks!

Is this truly meant to be a 4*4 atlas or a 4 rows and 1 column? Also, what are your settings in the beam data type? Have you set the texture tile to 1 and the texture tile distance to 0?

It is meant to be a 4x4 atlas.
In the example, I had the texture tile distance set to 100.
Setting the tile distance to 0 made it stretch as opposed to tile, which could be very useful in some cases.

So, I may have found out what is happening.

For some reason, the flipbook material is playing 1212 then 2121 then 3434 then 4343 when I have a 2x2 atlas with 1234 on it. I want it to play 1 then 2 then 3 then 4.

Is there a setting I have to change or something?


So I had to look at this with a coworker to figure out what is going on. When the beam tiles it doesn’t subdivide the mesh and fit the full uv space into each section, it simply repeats along the u. This means you can still use a tiling flipbook, but you have to pack all your frames vertically.

2 Likes

It helped me to understand the issue when I started thinking about the beam as a mesh particle instead of thinking about it like standard particle in cascade. You can’t modify the uv layout in a material but you can move and scale uv space within the uv layout of the mesh. This is exactly what the flipbook function does which is great when the uvs are in the 0-1 space, but breaks down otherwise.

1 Like

Oh my god you absolute madman, it works!

I may make a tutorial on this or something, cause this is information I haven’t found anywhere else.

4 Likes

Great!waiting for your tutorial! :+1::+1::+1: