Creating new material, only half of the texture shows up

Hello there,
I’m new to this whole vfx thing and am running into a problem while creating a new material that i want to preview on a specific mesh.
I tried changing the size of he mesh itself, but only the top half of the texture I made in Photoshop shows up on the mesh (see pictures)
Is there an easy solution to this?

I’m grateful for any help I can get!

Perhaps the UV Coordinates of the mesh is only half covered. :slight_smile:

Thank you! Could you maybe give me some pointers how Ii could fix that? :slight_smile:

Most 3D software for mesh output should have UV unwrapping/mapping options you can use to fix this.

You can check your UVs in Unreal by double-clicking your imported mesh and then use the UV drop-down menu in the asset preview window that pops up - selecting edges on the mesh should highlight the corresponding edge on the UVs, so if you select mesh edges that aren’t highlighted, you know they’re missing

Alright, thank you! :slight_smile: