Alpha erode help plz

hey everyone, noobieue4 here again. I am trying to learn how to make alpha erode thing, but i am running into this odd issue where the erosion would work, but it keeps looping? is there away to turn off the loop? is there something i can replace sine with that would make it not loop? or have the particle color control the speed/opacity of the alpha erosion?

tutorial one:

tutorial two:

the same thing happens here too really, the alpha would work fine, but it seems some what random or how often/fast the erode works when i tried to follow this tutorial

old demo/tutorial tried to follow it, but still had the same issue

here is what i tried to do… but sadly i have failed, the alpha loops kinda randomly, i wish i could control how fast it is, or when it erodes:

thanks again for all your help everyone!

1 Like

First tutorial had the answer for you, but it looked like it kept cutting to a new example right as the creator was replacing the sine/time chain with a dynamic parameter. Just replace the sine stuff with a dynamic parameter channel, remember to add the Dynamic Parameter to your emitter in Cascade, set it to constant curve and you should be golden.

hey travis, thanks for looking into this, i just tried out the dynamic parameter and it didn’t seem to work? sorry, this is all just super new to me. also, what is that 1x small box that he had the dynamic parameter go into?

The 1-x is the One Minus function, and it’s role here is to invert the values of your dynamic parameter so that they better match up with how particle color and alpha work. With it, anything with a value of 1 in your parameter will mean that nothing is subtracted from your texture, like it was fully opaque, or a value of 1 in your particle alpha. A value of 0 with the one minus connected would leave your texture fully eroded.

As for your particle system issue, if the video is of your own work, then you have your dynamic parameter set to Uniform for its Distribution. Uniform means that your Dynamic Parameter is picking a value between your Min and Max values that you have set, in this case between 1 and 0. By default, there is a little check box that says ‘Spawn Time Only’ that is unchecked. So what you are seeing is your Dynamic Parameter constantly picking random values between 1 and 0 to subtract from your texture over the particle’s life. Now, if you check the Spawn Time Only box, that means when any particle is initially spawned, it will pick a value between 1 and 0, and it will keep that value for the lifetime of the particle, instead of constantly bounced between your Min and Max.

What you need to do to get this to work how you want, is next to the Distribution drop down in your Dynamic Parameter, you will see a light grey dropdown box to the right that says Distribution Float Uniform. Click on that, and pick Distribution Constant Curve. This will give you a new drop down underneath Distribution, you’ll want to click the little triangle next to it to expand Constant Curve. By default you will have 0 array elements, so you’ll want to click the little + sign next to it twice. This will give you two new curve points. For the first, leave your In Val at 0.0 and change its Out Val to 1. Then go to the next array element underneath that (should have a 1 on the left) Change its In Val to 1, and its Out Val to 0.

In Val is your particle’s lifetime, 0 being the very start, 1 being the end (regardless of how long the particle lives) your Out Val is the value the Dynamic Parameter is outputing at that given time. For this setup, right as the particle spawns, it will have a value of 1 and the texture should be solid, and at the end, its value will be 0 and it will have dissolved your texture down to nothing.

I forgot to mention, checking Spawn Time Only is just used when setting your Distribution to Uniform. You don’t need to check that box if you are using a constant, or a constant curve.

wow it works!! thanks man!

now how do i key it so the leaf shows solid, for a long time then right before the life of the particle ends, it fades away?
it comes in with some of it dissolved already?

thanks again for all your help! this is super cool!

That depends, did you add the 1-x into your material? If you did, then having it at 0 will mean it’s completely dissolved out. You have the right idea with the graph for your dynamic parameter. Are you doing anything with your Color Over life?

hey, thanks for sticking around, sorry for the delay in my response, i can only practice UE4 late nightish…

so yeah, i am honestly not sure where to put the 1-x, tried putting it next the dynamic param, bit… i am not sure it is working properly… check out what i have so far:

Sure thing. You don’t need to multiply it by the sine node or anything. Just plug the output of your 1-x directly into Subtract, and you should be good

okay, i got something going here, but i am running to this new issue…
where the particle spawns almost a random spot of the erode? why does it do what it does in the preview window? like finish the cycle of the burn then restart? i tried changing the life of the particle but nothing really affects it? it just randomly chooses where to start or cut off

Hi! Try to use the node “Particle Relative Time” instead of “Time” into the shader network. :slight_smile:

yup. that worked, i also got rid of a couple of ceils, made the texture smoother. thank you all for your help!

Cool! You’re welcome! :wink: