Vfx-graph - Opaque Blend mode not showing my particles

Hello everyone!

I’m somewhat new to vfx and practicing by looking at tutorials.
The problem that I’m having is when I try to make any particle opaque in the visual effect graph, it just doesn’t show in any shape or form.
I can’t also seem to find anyone that has this problem, has this happened to anyone?

This is an example of what happens when I change the blend mode to opaque.

Thanks for your help.
Have a nice day.

That does sound funky. Could you provide a screenshot of the rest of your graph?

Yes sure, but I will let you know that this happens with all the graphs in the project that I try to render as opque.

Thanks for the help

When something like this happens try different previews if for example wireframe is there maybe there’re some alpha clip issues or if there’s no wireframe or particles problem may be somewhere else.

Hello again sorry for the late response. I tired to re-create this in my own project and could not achieve the same issues you are facing. I have however experienced the same issue when using custom shaders and it is usually a alpha or alpha clipping issue in the shader as mentioned above.

Have you tried using another mesh output node to see if it changes anything?

Running 2021.3.
I had the same issue, probably going through the same tutorial as the OP, and changing Mesh Output node to “Output Particle URP Lit Mesh” absolutely worked. Thanks @LankyGhoul for the fix!

1 Like

Not sure what type of collision node you’re using. Using Collide With Depth Buffer and opaque particles would cause this. Then they’d be colliding on themselves since they write to depth when opaque.

Edit: Yeah just read what you actually wrote. Take the above as some cool random trivia about VFX Graph instead :smiley: