VFX graph Color Intensity become white only?

Hi guys! I just recently started with VFX Graph and VFX as a whole. As I’m practicing, suddenly my color intensity isn’t working as intended. For context, I work in a team, and we’re all new to vfx graph. There’s 2 unity project that I use for practice and for the real project itself, and the one broken is in the real project.

In my Practice Unity, I can up the color intensity as far as 5 and still get a color on the sprite like this:
Color 2

But, in my Real Project Unity, at first it’s working just fine, but suddenly my color just become white:
Color 1

These 2 above have the same color at the intensity of 5.

I can get some color with intensity of 2 or 3, but it’s not the color that I want :frowning:

We already check the graphic setting, and nothing wrong there. I just don’t know why this happen and I don’t know what to search for this problem.
Any help is appreciated :smiling_face_with_tear:

Try to check post processing - it might be tonemapping or bloom.

100% what Qriva is saying. Any luminosity value above 1.0 (in your case 0.75 * 2.095) will converge towards white without tonemapping (and bloom makes this visible as well because the falloff from the white area which bloom creates is less intense than the center and therefore has visible color again).

Thanks for answering!

I’ve checked and in my real project and my practice project, there are still no post processing applied.

I’ve tried to compare any graphic setting I could find (URP setting, the vfx graph general setting on each game object, and anything from project setting), and find that both projects have the same numbers and settings.

Is there any other thing that can be checked? Or Is there any thing to be done from the VFX graph itself?

Maybe your main camera settings or vfx graph output settings (like blend mode).

The thing is your first yellow image has aura from bloom it means there is working post processing, meanwhile the second one has nothing like that - it just looks like any value above was clamped to 1.
Oh I know, do you have HDR enabled? Also, be sure you edit proper asset, you might have for example 3 different URP settings for quality levels and you can’t see changes if you edit the not active one.
The last thing to check might be color space setting, but I can’t see why it would cause what you described.

The thing is your first yellow image has aura from bloom it means there is working post processing

You might be right but the thing that’s making me have second thoughts is the fact that the intersection of the effect with the capsule in the first image doesn’t show any blooming over the capsule. It might be that the bloom we can see is drawn in the particle texture and it’s just more visible in the first picture thanks to the colors and the background.

I still would double check since tonemapping would be my first guess too…

After checking what you list, I’ve finally found the problem!
it appears that the Render setting of my camera is set to URP-Performant, and my coworker said that it limits some things, including how VFX Graph looks in my case.

Getting the Render Pipeline Asset to URP-High Fidelity back solved the problem. :smile:
Thank you for all the help!

URP-Performant has HDR disabled by default and this is (my bet) exact cause of the problem.

1 Like