Vertex Offset Doesn't Work on Particle Mesh Renderer

Hello, everyone,
I have a shader problem about particle system.
I want to make a shader like toon style smoke with vertex offset, It correctly works on 3d model, but doesn’t work on particle mesh renderer.

I’ve tried to add world position or normal node, but it just being extremely deformed and wrong shape.

Hope somebody know how to fix it, thanks a lot!

There is the shade node
https://imgur.com/I7AFC6r(High Resolution)


Gif
y4eyn-e24c4

It’s kinda hard to read through the nodes , but just from my personal experience there may be problems with spaces’ transforms…and you also have to make sure that all data is provided to the shader via custom vertex streams. I make prototypes on static meshes from time to time and then switch to the particle meshes and…it works just fine.

Edit : It’s also important to disable sRGB profile as well as Filtering for displacement and other aux. data from textures

yes, you are right it’s because of spaces transform. I have faced that.

Thanks for the answer, yes, it seems a vertex transform problem.
I would keep trying.