VAT texture map not working

Not sure why this is so difficult but inside Houdini my character UV’s are fine. I export the mesh out as a VAT softbody into UE5 and when I hookup the material its does not map correctly. What am I doing wrong?

I’ve never done VAT with characters but there’s a few things to check that come to mind (you might have already done these):

  1. in Houdini check what attributes you’re exporting. One time a soft body export broke for me because I exported the pivot and orient attributes – for soft body the only required variable is P

  2. I’m not sure if you did this, but make a material instance of your material and assign the exported textures to the respective position texture and rotation texture slots (the material itself looks to be setup correctly to me)

  3. Make sure you use the right import settings. If you go to the real-time-shaders tab on the Labs VAT node and select ‘Unreal Engine Content Plugin and Guides’ there’s a txt document in there that tells you what settings to use when you import into Unreal

Thanks for the info.

  1. Not sure how do I check that? Null node> info?
    2.Yes I think I did that correctly
  2. I will double check that and re-export just to be sure

Yea you can check the attributes with a null node → info and look to see if it says orient or pivot anywhere. It would also show up in the geometry spreadsheet. You can use an attribute delete node and in the drop down for attributes to delete see if orient or pivot is there and select them to delete.

This is what I see from the Null. I dont see a pivot or orient from the attdelete node when I check the dropdowns.

So that’s not the issue then… it was worth a guess. I’m unfortunately not too sure where to go from here :frowning_face:

No worries man. Thanks for the ideas. Hopefully someone can chime in because I have no idea where to look.