Unity scene viewport lags in editor when I preview a particle system, or reset the particle system from Shuriken

This is what it looks like.

I’m missing a lot of what’s happening the first second or so of my explosion where the FPS seems to be way below 30, and then it bumps up to smooth 60. When I hit reset on the particle system it begins to lag again and then get silky smooth after almost a second. And I’m not spawning any excess amount of particles with rediculous sizes or heavy shaders, it’s all quite simple really.

I’ve tried to google around but I haven’t found any answers.

Please help me with this very annoying issue!

Yea, so I restarted Unity.

Shame on me. :shushing_face:

Sometimes it’s due to Unity doing its thing.

I avoid that by click on an empty space, thus reseting the inspector window.

And sometimes when you select multiple particle systems to preview, it just lags. Usually I create an empty “parent” particle system and then select that one and play / replay.

1 Like

Thank you @Lush!
The next time Unity does its thing I will try this.
This is probably a useful tip for anyone starting out with Unity.

1 Like

Yeah, sometimes it happens to me and I just hide the inspector window by selecting another one like project settings or lighting, and the scene becomes smooth again :thinking:

image

1 Like

Thanks @Spyro :slight_smile: I’ve just started getting to know Unity so solving these little quirks is really nice!

1 Like