Unity - Amplify Shader Editor - Additive Shader for scrolling mesh particle problem

unity
ase
amplify-shader-edito

#1

Hey peoples,

I am brand new to Amplify Shader editor and I am getting stuck on creating an additive shader to scroll a texture across a mesh…

There are two problems… the first is the mesh is culling parts of itself that are behind it even though I thought I made it transparent…

Second to that, once the texture has finished scrolling, edges of the mesh remain visible, and I can’t seem to get rid of them…

In the main output node, these are my settings, anyone know where I am going wrong?

Cheers all


#2

Have you tried to change Render Queue to Transparent?


#3

I could’ve sworn I tried that and it didn’t work, but yeah, that solved the first problem, thanks :slight_smile: now I am still left with these artifacts after the tetxure has scrolled, so not too sure what to do about that…


#4

I’m not sure but checking Alpha to Covereage solve my problem with similar shader


#5

Can you try turning off lodding in your texture?
This looks a lot like working with a lower lod (because of low pixel coverage) blowing out your texture.

fair warning I’ve never use amplify either, I’m going off of experience with other shader editors.


#6

Hello, for a additive use


#7


#8

Thanks all will try this all this morning!